Compatibilit=c3=a9 du kernel 4.14 avec Xubuntu 17.10.1 =3f

Le
Pierre www.zetrader.fr
Hello, je pose la question au cas où il s'avère que Linux Mint 18.3 ne
soit pas très compatible avec les versions 4.14 du kernel, sachant que :
1) xubuntu 17.10.1 est plus récent que linux mint 18.3 et a par défaut
un kernel plus récent, il y a peut-être plus de chances que le kernel en
version 4.14 passe mieux ?
2) linut mint a des versions de kernel "customisés" pour plus de
stabilité, mais du coup accepte peut-être moins bien les versions de
kernel récentes "tel quel" du fait de tourner avec des versions de
kernel qui lui sont propres.
Pour le côté customisé des versions de kernel pour linux mint, je l'ai
lu sur quelques articles, un exemple :
https://www.linuxinsider.com/story/85050.html
"Linux Mint 18.3, the newest offering from a distribution that prides
itself on stability and usability, ships with a tweak of version 4.10."

Donc de ce que je comprends, c'est une version du kernel 4.10 propre à
Linux Mint (qui tourne bien cela dit, mais aucune des versions 4.10 ne
patche les failles de sécurité récentes).

Est-ce que des gens ici ont essayé des versions du kernel 4.14 avec
xubuntu 17.10.1 ? Cela tourne bien, pas de problèmes ? Sachant que cela
va du 4.14.0 à 4.14.15, quel kernel tourne le mieux pour vous ?
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jo Engo
Le #26461265
Le Thu, 25 Jan 2018 13:17:32 +0100, Pierre www.zetrader.fr a écrit :
Est-ce que des gens ici ont essayé des versions du kernel 4.14 avec
xubuntu 17.10.1 ?


Les soucis que tu as (et qui sont peut-être résoluble relativement
facilement) sont liés à ton matériel et non à la distribution. As-tu
essayé le kernel 4.14.x sur ta configuration actuelle ? quel souci
rencontre tu, quelles recherche as-tu effectuées ?
--
Chaque jour est veille pour les uns, lendemain pour d'autres,
mais aujourd'hui pour bien peu.
-+- Gilbert Cesbron (1913-1979), de petites choses. -+-
Pierre www.zetrader.fr
Le #26461270
Le 25/01/2018 à 14:39, Jo Engo a écrit :
Le Thu, 25 Jan 2018 13:17:32 +0100, Pierre www.zetrader.fr a écrit :
Est-ce que des gens ici ont essayé des versions du kernel 4.14 avec
xubuntu 17.10.1 ?

Les soucis que tu as (et qui sont peut-être résoluble relativement
facilement) sont liés à ton matériel et non à la distribution. As-tu
essayé le kernel 4.14.x sur ta configuration actuelle ? quel souci
rencontre tu, quelles recherche as-tu effectuées ?

Pas encore essayé la 4.14.x j'aimerais si possible avoir quelques
retours sur Linux Mint et la 4.14.x.
Pour le moment le seul retour que j'ai vu c'est que la 4.14.8 serait
plutôt stable, que les 4.14.9, 10, 11 poseraient des problèmes :
https://forums.linuxmint.com/viewtopic.php?t&1640
Cela "casserait" le dkms et aussi des problèmes pour ceux qui ont des
nvidia (ce n'est pas mon cas que je sache).
Le dkms par contre je le vois s'exécuter à chaque mise à jour, je ne
sais pas encore tout ce que cela implique si ça se met à déconner, a
priori c'est ça :
https://fr.wikipedia.org/wiki/Dynamic_Kernel_Module_Support
Si je n'ai pas plus de retours, je tenterais peut-être un coup de 4.14.8
car a priori de ce que j'ai vu ici et là, ce serait la plus fiable à
essayer.
Mon souci à la base c'est le wifi avec les kernels 4.13.0-26 et
4.13.0-31 qui m'ont été proposé par linux mint, et pas vu de solution en
cherchant sur ce problème (dans les topics de personnes ayant eu le même
problème, on ne leur propose pas de solution). il y a aussi dans une
version inférieure en 4.13 (je ne sais plus exactement laquelle) un gros
problème avec le bios sur des pc lenovo (j'ai un lenovo) ainsi que
d'autres pc, d'où l'idée que peut-être dans la 4.14 tout cela serait résolu.
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Jo Engo
Le #26461280
Le Thu, 25 Jan 2018 14:51:24 +0100, Pierre www.zetrader.fr a écrit :
Cela "casserait" le dkms et aussi des problèmes pour ceux qui ont des


J'ai l'impression que ça fait un bon moment que dkms est cassé chez moi.
C'est dommage que tu ne veux pas faire des test avec le kernel 4.14.8 (?)
enfin celui que tu accèdes par un ppa sur linux-mint parce que ça peut
être juste un driver propriétaire qui n'aime pas ton noyau ou bien qui
n'et plus embarqué ou un problème plus grave pour lequel tu peux apporter
ta contrib.
Mais bon tu es têtu et c'est difficile de te persuader de faire quelque
chose que tu as décidé de ne pas faire (Cf la configuration de ton
newsreader)
--
Nous vaincrons parce que nous sommes les plus forts.
-+- Paul Raynaud, 1939 -+-
Pierre www.zetrader.fr
Le #26461279
Le 25/01/2018 à 15:33, Jo Engo a écrit :
Le Thu, 25 Jan 2018 14:51:24 +0100, Pierre www.zetrader.fr a écrit :
Cela "casserait" le dkms et aussi des problèmes pour ceux qui ont des

J'ai l'impression que ça fait un bon moment que dkms est cassé chez moi.
C'est dommage que tu ne veux pas faire des test avec le kernel 4.14.8 (?)
enfin celui que tu accèdes par un ppa sur linux-mint parce que ça peut
être juste un driver propriétaire qui n'aime pas ton noyau ou bien qui
n'et plus embarqué ou un problème plus grave pour lequel tu peux apporter
ta contrib.
Mais bon tu es têtu et c'est difficile de te persuader de faire quelque
chose que tu as décidé de ne pas faire (Cf la configuration de ton
newsreader)

Bon la question du kernel 4.14.8 pour mon Linux Mint ne se pose plus, je
viens de le tester pour voir, même problème qu'avec 4.13.0-26 et
4.13.0-31 : plus de wifi, pas moyen de voir le réseau wifi, c'est comme
je n'avais pas de carte réseau wifi.
Je suis donc revenu au 4.10.0-42 qui marche bien.
Pour le moment le kernel le plus récent qui fonctionne bien, c'est le
kernel 4.13.0-21 mais sous Xubuntu 17.10.1, je n'ai pas encore testé ce
kernel sous linux mint, je vais peut-être tester pour voir, le résultat
serait intéressant vu qu'a priori la version buggée pour le bios n'est
plus en circulation :
- si 4.13.0-21 fonctionne bien sous mon linux mint, cela vient des
autres versions de kernel ou plutôt de la cohabitation driver/version de
noyau.
- si 4.13.0-21 fonctionne mal sous mon linux mint alors qu'il fonctionne
bien avec xubuntu 17.10.1 sur ce même ordi, alors le driver wifi de
linux mint a un problème que xubuntu n'a pas.
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Pierre www.zetrader.fr
Le #26461278
Le 25/01/2018 à 15:44, Pierre www.zetrader.fr a écrit :
Le 25/01/2018 à 15:33, Jo Engo a écrit :
Le Thu, 25 Jan 2018 14:51:24 +0100, Pierre www.zetrader.fr a écrit :
Cela "casserait" le dkms et aussi des problèmes pour ceux qui ont des

J'ai l'impression que ça fait un bon moment que dkms est cassé chez moi.
C'est dommage que tu ne veux pas faire des test avec le kernel 4.14.8 (?)
enfin celui que tu accèdes par un ppa sur linux-mint parce que ça peut
être juste un driver propriétaire qui n'aime pas ton noyau ou bien qui
n'et plus embarqué ou un problème plus grave pour lequel tu peux apporter
ta contrib.
Mais bon tu es têtu et c'est difficile de te persuader de faire quelque
chose que tu as décidé de ne pas faire (Cf la configuration de ton
newsreader)

Bon la question du kernel 4.14.8 pour mon Linux Mint ne se pose plus, je
viens de le tester pour voir, même problème qu'avec 4.13.0-26 et
4.13.0-31 : plus de wifi, pas moyen de voir le réseau wifi, c'est comme
je n'avais pas de carte réseau wifi.

Comme *si* je n'avais pas de carte réseau wifi pardon.
Je suis donc revenu au 4.10.0-42 qui marche bien.
Pour le moment le kernel le plus récent qui fonctionne bien, c'est le
kernel 4.13.0-21 mais sous Xubuntu 17.10.1, je n'ai pas encore testé ce
kernel sous linux mint, je vais peut-être tester pour voir, le résultat
serait intéressant vu qu'a priori la version buggée pour le bios n'est
plus en circulation :
- si 4.13.0-21 fonctionne bien sous mon linux mint, cela vient des
autres versions de kernel ou plutôt de la cohabitation driver/version de
noyau.
- si 4.13.0-21 fonctionne mal sous mon linux mint alors qu'il fonctionne
bien avec xubuntu 17.10.1 sur ce même ordi, alors le driver wifi de
linux mint a un problème que xubuntu n'a pas.

Il restera une question dans les 2 cas : est-ce que le kernel 4.13.0-26
ou 4.13.0-31 fonctionnerait sur ma machine si j'étais sous xubuntu 17.10.1 ?
La réponse à cette question je ne pourrais l'avoir que si j'installe
xubuntu et que je mets à jour le kernel sous xubuntu.
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Jo Engo
Le #26461286
Le Thu, 25 Jan 2018 15:44:12 +0100, Pierre www.zetrader.fr a écrit :
- si 4.13.0-21 fonctionne mal sous mon linux mint alors qu'il fonctionne
bien avec xubuntu 17.10.1 sur ce même ordi, alors le driver wifi de
linux mint a un problème que xubuntu n'a pas.


Ou ta version de dkms, ou que sais-je (l'ICC est plus souvent à l'origine
des problèmes qu'on l'imagine)
--
L'art si gamin ? Ébène béni ! Magistral !
-- Rapilly, Robert
Pierre www.zetrader.fr
Le #26461285
Le 25/01/2018 à 16:04, Jo Engo a écrit :
Le Thu, 25 Jan 2018 15:44:12 +0100, Pierre www.zetrader.fr a écrit :
- si 4.13.0-21 fonctionne mal sous mon linux mint alors qu'il fonctionne
bien avec xubuntu 17.10.1 sur ce même ordi, alors le driver wifi de
linux mint a un problème que xubuntu n'a pas.

Ou ta version de dkms, ou que sais-je (l'ICC est plus souvent à l'origine
des problèmes qu'on l'imagine)

Bon là, ça devient intéressant, j'ai testé le kernel 4.13.0-21 sous
linux mint et même problème : pas d'accès au wifi, comme si je n'avais
pas de carte réseau wifi, je ne peux voir aucun wifi.
Alors qu'en live usb xubuntu 17.10.1 qui utilise le kernel 4.13.0-21, la
connexion wifi marche sans aucun problème.
Il y a donc un problème avec mon linux mint, un problème dans la gestion
du gestion du driver wifi, incompatibilité avec plusieurs versions de
kernel (4.13.0-21, 4.13.0-26, 4.13.0-31, 4.14.8 et je ne sais combien
d'autres...), incompabilités que n'a peut-être pas xubuntu puisqu'avec
le kernel 4.13.0-21 en live usb, le wifi tourne bien.
Ou peut-être la version de dkms de mon linux mint, ou l'ICC de mon linux
mint comme tu dis, c'est quoi au fait l'ICC ?
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Jo Engo
Le #26461288
Le Thu, 25 Jan 2018 15:44:12 +0100, Pierre www.zetrader.fr a écrit :
Je suis donc revenu au 4.10.0-42 qui marche bien.

Problème avec dkms ultérieur à l'installation du 4.10 => les modules ne
s'installent pas ou mal sur les nouveaux kernel.
Essaie sans garantie du conseilleur
d'abord
sudo dpkg-reconfigure -plow dkms et s'il te pose des questions tu essaies
d'y répondre intelligemment sinon abort et demande ici
-ressaie le kernel à jour pour ton linux-mint
Si ça ne donne rien :
sudo apt install --reinstall dkms
puis idem teste le kernel kivabien
autrement si tu veux il y a un 4.15-rc8

--
La réalité, c'est ce qui refuse de disparaître
quand on a cessé d'y croire.
-+- Philip Kindred Dick (1928-1982) -+-
Eric Belhomme
Le #26461292
Le Thu, 25 Jan 2018 16:18:42 +0100, Pierre www.zetrader.fr a écrit :
Ou peut-être la version de dkms de mon linux mint, ou l'ICC de mon linux
mint comme tu dis, c'est quoi au fait l'ICC ?

ICC => Interface Chaise-Clavier...
Pour ton problème de module WiFi, tu cherches du mauvais coté : la quasi
totalité des cartes WiFi sur le marché ont besoin d'un firmware
(bloatware) qui est chargé par le module noyau durant son initialisation.
Ton problème est très probablement dû au fait que le firmware pour ta
carte n'est pas présent sur ton système.
Cherches dans les logs de ton noyau (dmesg), tu devrais trouver des
messages d'erreur de ton module wifi disant qu'il n'a pas réussi à
charger son firmware.
--
Rico
Jo Engo
Le #26461295
Le Thu, 25 Jan 2018 16:18:42 +0100, Pierre www.zetrader.fr a écrit :
c'est quoi au fait l'ICC ?


https://fr.wikipedia.org/wiki/Jargon_informatique#I
--
Seul a un caractère scientifique ce qui peut être réfuté. Ce qui n'est
pas réfutable relève de la magie ou de la mystique.
-+- Karl Popper -+-
Publicité
Poster une réponse
Anonyme