Montage d'un r=c3=a9pertoire d'un disque r=c3=a9seau sur un raspberry pi

Le
Didier
Bonjour,
Assez novice sur Linux (je n'ai pas trop de problème avec la ligne de
commande, sauf que je ne connais pas bien les commandes).
J'ai un assez vieux disque multimedia, sous linux, en réseau sur ma box,
qui contient un répertoire monté sur /tmp/hdd/volumes/HDD1. Je voudrais
le monter sur mon rapsberry pi, en réseau également sur ma box (j'ai
déjà monté d'autres disques comme une clé usb branchée sur ma box). Le
tout est en IP fixe.
J'ai enfin réussi à passer la bonne commande mount sans retour d'erreur,
mais mon point de montage est vide.
Internet n'est pas bavard sur cette situation; est-ce que vous verriez
des pistes à me conseiller ? (si vous avez besoin d'infos
complémentaires, a priori c'est dans mes cordes de les trouver en étant
guidé).
Merci.
Didier.
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Yliur
Le #26507195
Le Sat, 26 Jan 2019 19:00:47 +0100
Didier
Bonjour,
Assez novice sur Linux (je n'ai pas trop de problème avec la ligne de
commande, sauf que je ne connais pas bien les commandes).
J'ai un assez vieux disque multimedia, sous linux, en réseau sur ma
box, qui contient un répertoire monté sur /tmp/hdd/volumes/HDD1. Je
voudrais le monter sur mon rapsberry pi, en réseau également sur ma
box (j'ai déjà monté d'autres disques comme une clé usb branchée sur
ma box). Le tout est en IP fixe.
J'ai enfin réussi à passer la bonne commande mount sans retour
d'erreur, mais mon point de montage est vide.
Internet n'est pas bavard sur cette situation; est-ce que vous
verriez des pistes à me conseiller ? (si vous avez besoin d'infos
complémentaires, a priori c'est dans mes cordes de les trouver en
étant guidé).
Merci.
Didier.

Si je comprends bien, ton disque réseau est monté sur une première
machine et ça fonctionne bien ?
Parviens-tu à faire le montage à la main sur cette première machine ?
Pour vérifier que la commande est valide.
Peux-tu donner aussi la commande précise ?
Yliur
Le #26507194
Le Sat, 26 Jan 2019 19:00:47 +0100
Didier
Bonjour,
Assez novice sur Linux (je n'ai pas trop de problème avec la ligne de
commande, sauf que je ne connais pas bien les commandes).
J'ai un assez vieux disque multimedia, sous linux, en réseau sur ma
box, qui contient un répertoire monté sur /tmp/hdd/volumes/HDD1. Je
voudrais le monter sur mon rapsberry pi, en réseau également sur ma
box (j'ai déjà monté d'autres disques comme une clé usb branchée sur
ma box). Le tout est en IP fixe.
J'ai enfin réussi à passer la bonne commande mount sans retour
d'erreur, mais mon point de montage est vide.
Internet n'est pas bavard sur cette situation; est-ce que vous
verriez des pistes à me conseiller ? (si vous avez besoin d'infos
complémentaires, a priori c'est dans mes cordes de les trouver en
étant guidé).
Merci.
Didier.

Et quel est le résultat de la commande "mount" (sans paramètre) sur
la première machine en temps normal, sans avoir rien tenté, et sur le
pi après avoir exécuté la commande de montage ?
Didier
Le #26507207
Le 26/01/2019 à 19:24, Yliur a écrit :
Le Sat, 26 Jan 2019 19:00:47 +0100
Didier
Bonjour,
Assez novice sur Linux (je n'ai pas trop de problème avec la ligne de
commande, sauf que je ne connais pas bien les commandes).
J'ai un assez vieux disque multimedia, sous linux, en réseau sur ma
box, qui contient un répertoire monté sur /tmp/hdd/volumes/HDD1. Je
voudrais le monter sur mon rapsberry pi, en réseau également sur ma
box (j'ai déjà monté d'autres disques comme une clé usb branchée sur
ma box). Le tout est en IP fixe.
J'ai enfin réussi à passer la bonne commande mount sans retour
d'erreur, mais mon point de montage est vide.
Internet n'est pas bavard sur cette situation; est-ce que vous
verriez des pistes à me conseiller ? (si vous avez besoin d'infos
complémentaires, a priori c'est dans mes cordes de les trouver en
étant guidé).
Merci.
Didier.

Si je comprends bien, ton disque réseau est monté sur une première
machine et ça fonctionne bien ?
Parviens-tu à faire le montage à la main sur cette première machine ?
Pour vérifier que la commande est valide.
Peux-tu donner aussi la commande précise ?
En fait il est monté sur un poste Windows 7, sans souci particulier.

Ma commance mount dans fstab :
//192.168.1.101/tmp/hdd/volumes/HDD1/Photos /mnt/multimedia/Photos
ramfs defaults,ro,user,_netdev 0 0
(désolé pour le retour à la ligne).
Résultat de mount :
//192.168.1.101/tmp/hdd/volumes/HDD1/Photos on /mnt/multimedia/Photos
type ramfs (ro,nosuid,nodev,noexec,relatime,user,_netdev)
Et un ls -al de /mnt/multimedia/Photos :
total 4
drwxr-xr-x 2 root root 0 janv. 26 20:33 .
drwxr-xr-x 3 root root 4096 janv. 26 17:27 ..
D'ailleurs ça fait la même chose que le disque soit allumé (sous
tension) ou pas !
Sur le PC Windows 7 : tout y est bien.
Nicolas George
Le #26507212
Didier , dans le message
//192.168.1.101/tmp/hdd/volumes/HDD1/Photos /mnt/multimedia/Photos
ramfs defaults,ro,user,_netdev 0 0

« ramfs » ?
Didier
Le #26507288
Le 26/01/2019 à 20:57, Nicolas George a écrit :
Didier , dans le message
//192.168.1.101/tmp/hdd/volumes/HDD1/Photos /mnt/multimedia/Photos
ramfs defaults,ro,user,_netdev 0 0

« ramfs » ?

C'est que me dit linux sur mon vieux disque multimedia (je dis linux,
mais c'est un "truc" pas vraiment libre si j'ai bien compris, dédié
multimedia).
Avec d'autres systèmes de fichiers, j'avais soit une erreur 6 de mount
(pas vraiment trouvé d'explication claire sur cette erreur), soit un
message me disant que la ressource à monter n'exitait pas.
Finalement, en gratant sur le système, j'ai trouvé qu'il était sur un fs
ramfs, j'ai mis ça dans mount et plus d'erreur (idem dans fstab); j'ai
eu une seconde d'euphorie, le temps que je fasse un ls-al sur le
répertoire de montage : vide.
Didier.
Yliur
Le #26507292
Le Sun, 27 Jan 2019 16:14:57 +0100
Didier
Le 26/01/2019 à 20:57, Nicolas George a écrit :
Didier , dans le message
//192.168.1.101/tmp/hdd/volumes/HDD1/Photos /mnt/multimedia/Photos
ramfs defaults,ro,user,_netdev 0 0

« ramfs » ?

C'est que me dit linux sur mon vieux disque multimedia (je dis linux,
mais c'est un "truc" pas vraiment libre si j'ai bien compris, dédié
multimedia).
Avec d'autres systèmes de fichiers, j'avais soit une erreur 6 de
mount (pas vraiment trouvé d'explication claire sur cette erreur),
soit un message me disant que la ressource à monter n'exitait pas.
Finalement, en gratant sur le système, j'ai trouvé qu'il était sur un
fs ramfs, j'ai mis ça dans mount et plus d'erreur (idem dans fstab);
j'ai eu une seconde d'euphorie, le temps que je fasse un ls-al sur le
répertoire de montage : vide.
Didier.

Je ne sais pas où tu as "gratté", mais ramfs n'est pas un système de
fichier réseau. Ce n'est sans doute pas ça.
En fait tu n'as pas répondu précisément à une question précédente :
as-tu réussi à monter ce disque sur une autre machine Linux (distincte
du disque) ou bien la seule connexion réussie c'est sur la machine
Windows (ce qui laisserait entendre qu'il vaut mieux creuser du côté
des SF réseau Microsoft) ?
Jo Engo
Le #26507338
Le Sat, 26 Jan 2019 20:41:53 +0100, Didier a écrit :
D'ailleurs ça fait la même chose que le disque soit allumé (sous
tension)
ou pas !

Le plus simple est de le laisser allumé, ou bien de régler mieux ça.
--
19:35 KDE est au window manager ce que Mandrake est à Linux.
Didier
Le #26507345
Le 27/01/2019 à 17:21, Yliur a écrit :
Le Sun, 27 Jan 2019 16:14:57 +0100
Didier
Le 26/01/2019 à 20:57, Nicolas George a écrit :
Didier , dans le message
//192.168.1.101/tmp/hdd/volumes/HDD1/Photos /mnt/multimedia/Photos
ramfs defaults,ro,user,_netdev 0 0

« ramfs » ?

C'est que me dit linux sur mon vieux disque multimedia (je dis linux,
mais c'est un "truc" pas vraiment libre si j'ai bien compris, dédié
multimedia).
Avec d'autres systèmes de fichiers, j'avais soit une erreur 6 de
mount (pas vraiment trouvé d'explication claire sur cette erreur),
soit un message me disant que la ressource à monter n'exitait pas.
Finalement, en gratant sur le système, j'ai trouvé qu'il était sur un
fs ramfs, j'ai mis ça dans mount et plus d'erreur (idem dans fstab);
j'ai eu une seconde d'euphorie, le temps que je fasse un ls-al sur le
répertoire de montage : vide.
Didier.

Je ne sais pas où tu as "gratté", mais ramfs n'est pas un système de
fichier réseau. Ce n'est sans doute pas ça.
En fait tu n'as pas répondu précisément à une question précédente :
as-tu réussi à monter ce disque sur une autre machine Linux (distincte
du disque) ou bien la seule connexion réussie c'est sur la machine
Windows (ce qui laisserait entendre qu'il vaut mieux creuser du côté
des SF réseau Microsoft) ?

Le seul montage réussi de ce répertoire de ce disque réseau est bien sur
une machine windows; donc pas de souci pour moi côté microsoft, sinon je
ne serais pas venu sur ce groupe.
Le ramfs je l'ai trouvé comme résultat de la commande mount :
/ # mount
/dev/root on / type yaffs2 (ro,noatime)
none on /dev type devfs (rw)
none on /proc type proc (rw,nodiratime)
devpts on /dev/pts type devpts (rw)
none on /sys type sysfs (rw)
none on /tmp type ramfs (rw)
/dev/mtdblock/2 on /usr/local/etc type yaffs (rw,noatime)
/dev/rd/0 on /mnt/rd type vfat
(rw,nodiratime,fmask22,dmask22,codepage=cp437,iocharset=iso8859-1)
/dev/scsi/host0/bus0/target0/lun0/part1 on /tmp/hdd/volumes/HDD1 type
ufsd (rw,nodiratime)
/dev/scsi/host0/bus0/target0/lun0/part3 on /tmp/hdd/root type ext3 (rw)
Le fs ramfs est sur /tmp (5ème ligne), et mon répertoire à monter est
dans /tmp. D'où mon essai avec ramfs (mount ne proteste pas).
C'est celui de l'avant dernière ligne (/tmp/hdd/volumes/HDD1) que je
veux monter sur mon raspberry; mais mount refuse le fs type ufsd sur le
raspberry.
Didier.
Yliur
Le #26507419
Le Sun, 27 Jan 2019 22:57:02 +0100
Didier
Le seul montage réussi de ce répertoire de ce disque réseau est bien
sur une machine windows; donc pas de souci pour moi côté microsoft,
sinon je ne serais pas venu sur ce groupe.

Oui mais cette information est importante.
Le ramfs je l'ai trouvé comme résultat de la commande mount :

Sur le disque multimédia directement je suppose ? Tu as un moyen de t'y
connecter via ssh par exemple ?
/ # mount
none on /tmp type ramfs (rw)

Ça c'est /tmp : ce répertoire va contenir un système de fichiers
stocké en mémoire, donc perdu à chaque extinction de la machine. C'est
courant dans les distributions Linux maintenant je pense.
/dev/scsi/host0/bus0/target0/lun0/part1 on /tmp/hdd/volumes/HDD1 type
ufsd (rw,nodiratime)

Ça c'est autre chose, qui se trouve dans un sous-répertoire de /tmp.
Est-ce que tu vois bien comment fonctionnent les montages ? Tu as des
arborescences sur différents supports/partitions, et tu les greffes les
unes sur les autres. Donc ici montage d'un SF en mémoire dans /tmp, on
crée des dossiers dedans (stockés uniquement en mémoire donc), dans
l'un d'eux (/tmp/hdd/volumes/HDD1) on vient greffer d'autres
répertoires et fichiers qui se trouvent dans un autre système de
fichiers (ufs), stockés d'une autre manière. Donc au final les deux
arborescences sont mêlées, mais leurs fichiers et répertoires sont
stockés de manière très différentes, à des endroits différents.
Le fs ramfs est sur /tmp (5ème ligne), et mon répertoire à monter est
dans /tmp. D'où mon essai avec ramfs (mount ne proteste pas).
C'est celui de l'avant dernière ligne (/tmp/hdd/volumes/HDD1) que je
veux monter sur mon raspberry; mais mount refuse le fs type ufsd sur
le raspberry.

Déjà les fichiers qui t'intéressent ne sont pas dans un SF de type
ramfs, bien qu'ils apparaissent dans un sous-répertoire. Mais surtout
ces systèmes de fichiers (ramfs et ufs) correspondent à la manière dont
les fichiers sont stockés sur le disque multimédia : tu ne peux pas les
monter sur une machine distante.
S'ils sont accessible depuis le réseau, c'est qu'il se trouve sur ce
disque multimédia un service de partage de fichiers sur le réseau. Si
c'est accessible depuis Windows, je suppose qu'il faut se tourner vers
des choses comme SMB/CIFS. Sous Linux, je pense que c'est Samba qui te
permet d'y accéder. Tu trouveras sans doute de la doc sur le site
d'Ubuntu par exemple, ou bien quelqu'un ici saura comment faire le
montage, je n'ai jamais essayé.
Je ne sais pas comment vérifier quels services tournent sur cette
machine / disque multimédia : si ça inspire quelqu'un, ça pourrait
permettre de déterminer lequel est utilisé pour partager les fichiers.
yamo'
Le #26507448
Salut,
Didier wrote on 1/27/19 10:57 PM:
/dev/scsi/host0/bus0/target0/lun0/part1 on /tmp/hdd/volumes/HDD1 type
ufsd (rw,nodiratime)
/dev/scsi/host0/bus0/target0/lun0/part3 on /tmp/hdd/root type ext3 (rw)
Le fs ramfs est sur /tmp (5ème ligne), et mon répertoire à monter est
dans /tmp. D'où mon essai avec ramfs (mount ne proteste pas).


Ce que je vois surtout c'est que c'est du ufsd.
Tu peux pas le monter ailleurs du genre /mnt?
--
Stéphane
Publicité
Poster une réponse
Anonyme