ssh -X et charge processeur

Le
Lulu
Yo!

Toujours avec mon portable MSI avec écran et clavier mort

Je dois visiter des sites fortement consommateurs de ressources pour
remplacer le pauvre Lenovo que j'utilise (un N3710 acheté 300 euros il y
a déjà 3 ans) et complètement à la ramasse sur les sites un peu chargés.

Je pensais qu'en lançant un firefox depuis mon portable MSI à l'écran HS
(un core i5 M460) au moins 2 fois plus balèze, la charge machine serait
demandé à ce PC

Mais non, la charge de ce serveur X reste à 0 alors que celle de mon
lenovo atteint les 300 à 400 %, comme si le firefox lancé depuis le MSI
était en fait exécuté sur mon pauvre Lenovo.

Y'a quelque chose que j'ai raté ?

Comment faire en sorte de bénéficier des performances du MSI et de ne
déporter que l'affichage sur mon Lénovo sans charger ce dernier ?

Merci de vos avis.
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas George
Le #26542710
Lulu , dans le message écrit :
Mais non, la charge de ce serveur X reste à 0 alors que celle de mon
lenovo atteint les 300 à 400 %, comme si le firefox lancé depuis le MSI
était en fait exécuté sur mon pauvre Lenovo.

Quels sont les processus qui consomment ?
Lulu
Le #26542714
Le 09-04-2020, Lulu
Yo!
Toujours avec mon portable MSI avec écran et clavier mort...
Je dois visiter des sites fortement consommateurs de ressources pour
remplacer le pauvre Lenovo que j'utilise (un N3710 acheté 300 euros il y
a déjà 3 ans) et complètement à la ramasse sur les sites un peu chargés.
Je pensais qu'en lançant un firefox depuis mon portable MSI à l'écran HS
(un core i5 M460) au moins 2 fois plus balèze, la charge machine serait
demandé à ce PC...
Mais non, la charge de ce serveur X reste à 0 alors que celle de mon
lenovo atteint les 300 à 400 %, comme si le firefox lancé depuis le MSI
était en fait exécuté sur mon pauvre Lenovo.
Y'a quelque chose que j'ai raté ?
Comment faire en sorte de bénéficier des performances du MSI et de ne
déporter que l'affichage sur mon Lénovo sans charger ce dernier ?
Merci de vos avis.

Oops...
Je me rends compte que je devrais sans doute préciser comment,
techniquement, j'exécute firefox sur mon MSI supposé largement plus
puissant que mon pauvre Lenovo :
Je me connecte sur le MSI avec ssh -X -p 8222 pour obtenir un
prompt sur la machine 'dot' qui est le MSI avec core i5 M 460
Et dans ce propmpt, je tape simplement 'firefox' qui ouvre bien
une nouvelle fenêtre firefox.
Seulement je peux vérifier en direct que mon MSI ne branle rien pendant
que mon client Lenovo est surchargé.
Lulu
Le #26542715
Le 09-04-2020, Nicolas George
Lulu , dans le message écrit :
Mais non, la charge de ce serveur X reste à 0 alors que celle de mon
lenovo atteint les 300 à 400 %, comme si le firefox lancé depuis le
MSI était en fait exécuté sur mon pauvre Lenovo.

Quels sont les processus qui consomment ?

Web Content et cinnamon d'après htop.
Nicolas George
Le #26542719
Lulu , dans le message écrit :
Web Content et cinnamon d'après htop.

Donc Firefox. Donc tu as lancé htop sur la même machine que Firefox. Je
soupçonne que tu t'es embrouillé quelque part.
Philippe Weill
Le #26542729
Le 09/04/2020 à 21:28, Lulu a écrit :
Yo!
Toujours avec mon portable MSI avec écran et clavier mort...
Je dois visiter des sites fortement consommateurs de ressources pour
remplacer le pauvre Lenovo que j'utilise (un N3710 acheté 300 euros il y
a déjà 3 ans) et complètement à la ramasse sur les sites un peu chargés.
Je pensais qu'en lançant un firefox depuis mon portable MSI à l'écran HS
(un core i5 M460) au moins 2 fois plus balèze, la charge machine serait
demandé à ce PC...
Mais non, la charge de ce serveur X reste à 0 alors que celle de mon
lenovo atteint les 300 à 400 %, comme si le firefox lancé depuis le MSI
était en fait exécuté sur mon pauvre Lenovo.
Y'a quelque chose que j'ai raté ?


oui , il faut que tu lance firefox sur le MSI comme ceci
firefox --no-remote
Comment faire en sorte de bénéficier des performances du MSI et de ne
déporter que l'affichage sur mon Lénovo sans charger ce dernier ?
Merci de vos avis.
Lulu
Le #26542847
Le 09-04-2020, Nicolas George
Lulu , dans le message écrit :
Web Content et cinnamon d'après htop.

Donc Firefox. Donc tu as lancé htop sur la même machine que Firefox. Je
soupçonne que tu t'es embrouillé quelque part.

Sans doute...
Reprenons :
Sur mon Lenovo (avec écran et clavier fonctionnel), avec un pauvre
N3710 comme processeur et 4 Go de RAM, j'ouvre une session ssh sur mon
MSI ayant résisté à un orage au prix d'un écran et d'un clavier HS, doté
d'un Core I5-M460 (au moins 3 fois plus puissant que le N3710) et de 4
GB de RAM avec la commande 'ssh -X -p 8222', je tape
mon mot de passe puis 'firefox'. (sans le '--no-remote' conseillé par
Philippe dans un premier temps).
Firefox s'ouvre sur l'écran du Lenovo après au moins 20 secondes, la
navigation est extrêment lente bien que les 4 onglets ouverts soient très
légers (pas de zigouigouis flashy, juste du texte avec quelques images
légères) : 10 secondes pour changer d'onglet, autant pour en ouvrir un
nouveau, au moins 5 secondes pour que le texte saisi dans la barre
d'adresse s'affiche et autant pour qu'un appui sur "page down" fasse
défiler la page (qu'on voit défiler ligne à ligne).
C'est quasi-inutilisable (et je n'ai pas essayé d'horreur comme
fnac.com)
Pendant ce temps, le MSI (serveur X) a une charge inférieure à 20 %, son
processeur ne tourne qu'à 1,2 Ghz (le max est à 2,53) et je vois dans le
top que j'ai lancé dans un terminal loggué par ssh sur le MSI que le
processus firefox fait des petites pointes à 10-12% de CPU.
Sur le Lenovo (client X) la charge est au alentours de 60%, avec des
pointes à 40% de CPU pour cinnamon (mon bureau) et 15% à 25% pour Xorg.
Comme j'ai, dans le terminal depuis lequel j'ai lancé firefox (le
terminal ouvert sur le MSI) eu le message « (firefox:23833):
LIBDBUSMENU-GLIB-WARNING **: 10:39:19.681: Unable to get session bus:
Could not connect: Connexion refusée », j'entreprends une petite
recherche qui me suggère d'installer le paquet dbus-x11, mais il
est déjà installé.
J'ai vu aussi qu'on pouvait saisir 'export $(dbus-launch)'
Puis un autre message : « Gdk-Message: 10:26:54.018: firefox: Fatal IO
error 11 (Ressource temporairement non disponible) on X server
localhost:10.0. »
Je magouille avec dbus... notamment je supprime les deux fichiers dans
~/.dbus/session-bus mais si j'arrive à stopper dbus, je n'arrive pas à
le relancer (c'est par design semble-t-il).
Je redemarre le serveur MSI et je m'y reconnecte avec 'ssh -X
-p 8222'.
Je tape 'dbus-launch' puis 'export $(dbus-launch)' et finalement
'dbus-launch firefox --no-remote'
Pas d'erreur affichée dans ce terminal.
La charge de mon client Lenovo navigue entre 60% et 150% avec xorg et
cinammon qui bouffent entre 15 et 25% du CPU chacun.
Et alors que son N3710 est limité à 1,6 GHz, un 'grep Hz /proc/cpuinfo'
raconte :
model name : Intel(R) Pentium(R) CPU N3710 @ 1.60GHz
cpu MHz : 1532.194
model name : Intel(R) Pentium(R) CPU N3710 @ 1.60GHz
cpu MHz : 1517.438
model name : Intel(R) Pentium(R) CPU N3710 @ 1.60GHz
cpu MHz : 1522.197
model name : Intel(R) Pentium(R) CPU N3710 @ 1.60GHz
cpu MHz : 1524.421
donc le proc tourne à fond alors que je n'ai qu'un terminal avec 8
onglets ouverts (c'est terminator que je recommande chaudement)
Pendant ce temps-là, le serveur MSI se branle la nouille : processeur à
1,3 GHz et charge machine oscillant entre 0% et 2%...
Quand je rafaraichi une page (toujours légère), je vois que le processus
firefox fait une petite pointe à 6 ou 7% de CPU.
Et firefox est toujours inutilisable...
Comment faire en sorte que ce soit le serveur qui mouline ?
Cependant, j'ai maintenant un autre problème : le répertoire
~/.dbus/session-bus ne s'est pas repeuplé de ses deux fichiers supprimé
suite à astuce trouvée sur le web (j'ai pourtant pu relancer xorg sans
message d'erreur).
Merci de votre aide.
Nicolas George
Le #26542861
Lulu , dans le message écrit :
Reprenons :

TL;DR. Rédige ton autobiographie ou accepte mon aide pour résoudre ton
problème, mais in faut choisir ;-)
Pour commencer, fixons les idées de manière synthétique, parce que tu
t'embrouilles dans notations.
Si j'ai bien compris, tu as une machine puissante sans écran, disons
MPSE, et une machine lente avec écran, disons MLAE.
Déjà, le SERVERU X11, c'est là où il y a l'écran, presque toujours, donc
MLAE. J'ai vu plusieurs fois des incohérence sur ce point. Firefox est
le CLIENT X11, quelle que soit la machine où il tourne.
Ne t'occupe pas de DBus, Firefox n'en a pas beaucoup besoin.
Premièrement, assure-toi que Firefox ne tourne, au départ, sur aucune
des deux machines.
Ensuite, lance des top sur les deux machines, pour surveiller.
Là, lance Firefox sur MPSE.
Normalement, tu devrais voir firefox et des processus Web-machin sur
le top de MPSE, et Xorg qui s'agite sur le top de MLAE. En aucun cas un
firefox ou Web-machin sur MLAE.
Philippe Weill
Le #26542886
Le 10/04/2020 à 20:27, Nicolas George a écrit :
Lulu , dans le message écrit :
Reprenons :

TL;DR. Rédige ton autobiographie ou accepte mon aide pour résoudre ton
problème, mais in faut choisir ;-)
Pour commencer, fixons les idées de manière synthétique, parce que tu
t'embrouilles dans notations.
Si j'ai bien compris, tu as une machine puissante sans écran, disons
MPSE, et une machine lente avec écran, disons MLAE.

a priori c'est ce que j'ai compris
mais je me demande si la meilleure solution pour lui ne serait pas
de monter une solution type déport de session
vnc,x2go ...

Déjà, le SERVERU X11, c'est là où il y a l'écran, presque toujours, donc
MLAE. J'ai vu plusieurs fois des incohérence sur ce point. Firefox est
le CLIENT X11, quelle que soit la machine où il tourne.
Ne t'occupe pas de DBus, Firefox n'en a pas beaucoup besoin.
Premièrement, assure-toi que Firefox ne tourne, au départ, sur aucune
des deux machines.
Ensuite, lance des top sur les deux machines, pour surveiller.
Là, lance Firefox sur MPSE.
Normalement, tu devrais voir firefox et des processus Web-machin sur
le top de MPSE, et Xorg qui s'agite sur le top de MLAE. En aucun cas un
firefox ou Web-machin sur MLAE.
Nicolas George
Le #26542905
Philippe Weill , dans le message écrit :
mais je me demande si la meilleure solution pour lui ne serait pas
de monter une solution type déport de session

La solution à un problème passe rarement par le fait de renoncer à le
comprendre.
Lulu
Le #26542981
Le 10-04-2020, Nicolas George
Lulu , dans le message écrit :
Reprenons :

TL;DR. Rédige ton autobiographie ou accepte mon aide pour résoudre
ton problème, mais in faut choisir ;-)

J'ai voulu être le plus complet au détriment de la concision.
Pour commencer, fixons les idées de manière synthétique, parce que tu
t'embrouilles dans notations.

Ah...
Si j'ai bien compris, tu as une machine puissante sans écran, disons
MPSE, et une machine lente avec écran, disons MLAE.

Oui : MPSE est le MSI dans le message auquel tu réponds et MLAE le
Lenovo.
Mais gardons ta notation.
Déjà, le SERVERU X11, c'est là où il y a l'écran, presque toujours,
donc MLAE. J'ai vu plusieurs fois des incohérence sur ce point.
Firefox est le CLIENT X11, quelle que soit la machine où il tourne.

0K, je note. C'est vrai que j'ai notamment lu
http://linux.developpez.com/formation_debian/export-display.html qui
présente la machine sur laquelle tourne Firefox comme le serveur.
Ne t'occupe pas de DBus, Firefox n'en a pas beaucoup besoin.

0K
Premièrement, assure-toi que Firefox ne tourne, au départ, sur aucune
des deux machines.

0K.
Ensuite, lance des top sur les deux machines, pour surveiller.

0K.
Là, lance Firefox sur MPSE.

0K.
Firefox montre d'ailleurs "(sur Dottore)" dans sa barre de titre,
sachant que Dottore est le nom de la machine MPSE sur le réseau.
Normalement, tu devrais voir firefox et des processus Web-machin sur
le top de MPSE, et Xorg qui s'agite sur le top de MLAE. En aucun cas un
firefox ou Web-machin sur MLAE.

C'est effectivement ce qui se passe.
La charge machine de MPSE monte à 150% avec firefox et des WebContent et
WebExtensions, pour se stabiliser après quelques minutes à 50% à 70%.
La charge de MLAE augemente à 60, 70% avec cinnamon qui occupe le plus
de CPU (environ 30% pour cinnamon + 10 à 15% pour Xorg).
Mais firefox est quasi-inutilisable : 5 secondes pour passer d'un onglet
à l'autre, défilement des pages (très légères) ligne à ligne...
C'est ça que j'ai du mal à comprendre, que firefox s'exécute sur la
machine puissante avec son affichage sur la machine lente qui est
beaucoup plus lent que si je l'avais lancé directement sur la machine
lente...
Publicité
Poster une réponse
Anonyme