Table du système de fichiers incorrecte

Le
rockaunord
Bonjour,

Je suis confronté à un pb avec le Mac d'un ami (G3 beige sous OS 8.5), sans
aucune raison, après 2 mois d'inactivité, le Mac demarre avec ce message
d'erreur "Table du système de fichiers incorrecte". Comme conseillé
antérieurement dans un poste, j'ai été voir sur
http://docs.info.apple.com/article.html?artnum`837, mais ca ne semble pas
correspondre à son cas de figure (pas de periph USB en fonction sur la
machine). Impossible aussi de démarrer en désactivant les extensions, j'ai
toujours ce même message.

Aux grands maux, les grands remèdes, on décide de booter sur un CD Mac OS
8.5, rien à faire (meme avec la touche C gardée enfoncée), idem avec un CD
Mac OS 9.

Que faire, où intervenir ?

Dois je essayer de bidouiller une disquette systeme pour démarrer dessus ?
Zapper la PRAM ?

D'avance meci

Christophe
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jc
Le #17027841
rockaunord
Que faire, où intervenir ?

Dois je essayer de bidouiller une disquette systeme pour démarrer dessus ?
Zapper la PRAM ?




Regarde dans les archives du groupe, tu trouveras beaucoup de pistes
possibles, dont il semble malheureusement qu'aucune ne fonctionne
systématiquement.

En attendant, zapper la PRAM permet effectivement de démarrer en évitant
cet irritant message, mais il réapparaîtra au démarrage suivant.

Une des pistes consiste à démarrer en zappant la PRAM, renommer les
extensions Microsoft en insérant un ~ au début de leur nom pour qu'elles
se chargent en dernier, et redémarrer.

Si aucune piste ne fonctionne et les incantations vaudoues avec poulet
égorgé non plus, il ne reste malheureusement que la réinstall complète
du système.

--
J.C.
gilles
Le #17027831
rockaunord
Bonjour,

Je suis confronté à un pb avec le Mac d'un ami (G3 beige sous OS 8.5), sans
aucune raison, après 2 mois d'inactivité, le Mac demarre avec ce message
d'erreur "Table du système de fichiers incorrecte". Comme conseillé
antérieurement dans un poste, j'ai été voir sur
http://docs.info.apple.com/article.html?artnum`837, mais ca ne semble pas
correspondre à son cas de figure (pas de periph USB en fonction sur la
machine). Impossible aussi de démarrer en désactivant les extensions, j'ai
toujours ce même message.



Merde, c'est vraiment bizarre tout ça car ce problème, en principe,
n'intervient jamais que sur des machines avec USB en natif en OS 9.
Très très bizarre que ça t'arrive sur un G3 beige, sous 8.5 qui plus
est.

Aux grands maux, les grands remèdes, on décide de booter sur un CD Mac OS
8.5, rien à faire (meme avec la touche C gardée enfoncée), idem avec un CD
Mac OS 9.



tu es sur que ça démarre bien sur le CD ?

Que faire, où intervenir ?



Vérifier que tout est bien en place dans le G3 (barrettes mémoire, carte
son, etc.). si tu as DiskWarrior tu peux tenter de réparer le catalogue
du disque.
Faire une sauvegarde des fichiers, aussi, si possible, avant les
interventions.

Dois je essayer de bidouiller une disquette systeme pour démarrer dessus ?
Zapper la PRAM ?



oui, zapper la pram c'est un bon début. je peux t'envoyer une image
disque de disquette de boot en 8.5 (sinon elle est aussi dans les CD du
8.5, dans les compléments CD je crois ou dans le dossier utilitaires).

Débranche le disque dur et essaye de booter sur CD comme ça, ça ne
résoudra rien dans un premier temps mais ça permet de confirmer que le
problème vient du G3 et pas de son disque dur.
phpinfo
Le #17027821
rockaunord
Dois je essayer de bidouiller une disquette systeme pour démarrer dessus ?
Zapper la PRAM ?



- Zapper la PRAM est la première chose a tenter (si ça marche, c'est que
la pile est défaillante)
- Seconde chose à tester : redémarrer sur CD, virer dans le dossier
extensions tout les trucs bizarre externe à Apple et redémarrer

Mais comme le dit Gilles, ce problème est rencontré avec OS9 et pas
OS8.5... d'habitude... Donc ce n'est peut être pas le célèbre problème
connut sous le nom de "The Thing".


--
Pierre-Alain Dorange

Vidéo, DV et QuickTime pour Mac Clarus, the DogCow
Rockaunord
Le #17027761
Bonsoir,

Merci pour vos réponses, mais le problème reste entier : impossible de
démarrer sur un cd d'install (donc impossible de réinstaller).
Les extensions ne se désactivent pas non plus (même avec la touche majuscule
enfoncée au boot).
Un zap de PRAM ne change rien, j'ai toujours le même message au démarrage.

Je pense qu'il s'agit d'un OS 8.5 (de mémoire un G3 ne tourne pas sous OS
8.0), mais pas d'un OS 9 (cette personne vient justement de me racheter un
OS 9 original, mais avec tous ces problèmes, on n'a pas encore pu
l'installer).

J'ai préparé une disquette de boot à l'aide de l'utilitaire présant sur le
cd d'installation, on verra bien.

Sinon, j'ai un disque IDE (ancien disque d'un pc que j'ai démonté), est ce
que je peux envisager de l'installer, monter dessus un système Mac, pour
ensuite mettre en deuxième disque celui avec l'OS défaillant de manière à
l'initialiser et tout remettre à plat.

Encore merci pour votre aide.

Christophe
la_cantine
Le #17027741
Gilles Aurejac
Merde, c'est vraiment bizarre tout ça car ce problème, en principe,
n'intervient jamais que sur des machines avec USB en natif en OS 9.
Très très bizarre que ça t'arrive sur un G3 beige, sous 8.5 qui plus
est.



Non, c'est normal : la table du système de fichiers est donc dans le cas
de Christophe vraiment incorrecte, car l'erreur et la cause de l'erreur
existent ... bel et bien. C'est pas parce qu'avec un certain OS ça le
fait sans le faire ...

Pour Christophe : un coup de DiskWarrior s'impose. Mettre à jour le
pilote de DD concerné aussi.



--
Roberto

UBI SOLITUDINEM FACIUNT, PACEM APPELLANT.
pmanet
Le #17023911
Le Cantinier
a table du système de fichiers est donc dans le cas
de Christophe vraiment incorrecte, car l'erreur et la cause de l'erreur
existent ... bel et bien.



fouchtra ! en voilà une remarque qu'elle est bonne !

s'il n'a pas disk warrior, il peut commencer avec SOS disque (si
possible la version 8.6.1, qui est la plus souple).

--
Philippe Manet

gilles
Le #17023891
Rockaunord
Merci pour vos réponses, mais le problème reste entier : impossible de
démarrer sur un cd d'install (donc impossible de réinstaller).
Les extensions ne se désactivent pas non plus (même avec la touche majuscule
enfoncée au boot).
Un zap de PRAM ne change rien, j'ai toujours le même message au démarrage.



Ok, et tu as essayé de booter sur CD seul avec disque dur débranché ? ça
donne quoi ?
A mon avis ton disque dur a un pète au casque et c'est lui qui empêche
le boot sur tout autre disque ou CD

Note que les recherches dans les forums ne te donneront pas grand chose
car la plupart du temps le problème de table de système de fichiers ne
concerne que des iMac ou G3/G4 à bus USB sous OS 9 français.
Ton problème vient plutot d'une corruption du disque dur (table de
partition ou catalogue).

Je pense qu'il s'agit d'un OS 8.5 (de mémoire un G3 ne tourne pas sous OS
8.0),



8.0 ça tourne pas 8.1 ça tourne

mais pas d'un OS 9 (cette personne vient justement de me racheter un
OS 9 original, mais avec tous ces problèmes, on n'a pas encore pu
l'installer).

J'ai préparé une disquette de boot à l'aide de l'utilitaire présant sur le
cd d'installation, on verra bien.



Ok

Sinon, j'ai un disque IDE (ancien disque d'un pc que j'ai démonté), est ce
que je peux envisager de l'installer, monter dessus un système Mac, pour
ensuite mettre en deuxième disque celui avec l'OS défaillant de manière à
l'initialiser et tout remettre à plat.



aucun problème; attention pas de gestion maitre / esclave sur les bus
IDE des premiers G3 donc un seul périph par nappe IDE.
Donc dans un premier temps tu remplaces le DD du G3 par ton disque de
secours et boote sur CD pour le formater et installer un OS, après tu
remplaces le lecteur CD par le disque d'origine du G3.
michele
Le #17023861
TdFI sur un 8.5 ? Bizarre. Ça concerne OS 9.x

Voilà ce que j'ai récolté :

TdFI est un pb de "gestion de la mémoire" au démarrage en liaison avec
l'USB. C'est un problème dans la création d'une table de variables du
système au moment du chargement des extensions. Le remède est de faire
quelque chose qui modifie l'enchainement des diverses séquence de
chargement/initialisation des extensions au boot (donc démarrer sans
extension, débrancher le clavier, modifier l'ordre de chargement des
extension..). C'est un bug qui se "crée" pendant le boot, il n'est pas
présent sur le disque. ce n'est pas de reformater qui le règle (si ce
n'est que en réinstallant le système on touche aux extension donc TdFI
disparait). TdFI ne "casse" rien sur le disque, c'est un bug propre ;-)

----------

(ça, c'est moi)
Bug de francisation de mac OS 9.x.
- Solution définitive : installer un mac OS 9.x us.
- Solution pour garder son OS 9.x français :
Tu redemarres en zappant la PRAM (démarrer en ayant pressé les
touches commande, option, la lettre "p" et la lettre "r"). Attendre
3 "boïngs" (sons de démarrage) avant de lacher.
Tu modifies ton dossier extension de n'importe quelle façon.
Entr'autres, tu peux, par exemple : virer une extension qui t'est
inutile ou en rajouter une que tu avais enlevée. Ma solution préférée :
mettre la lettre "z" devant les extensions Microsoft afin de les faire
se charger en dernier.

----------

(François Grieu)
A) le problème survient, ou pas, de manière plutôt répétable, en
fonction d'une conjonction d'au moins
1) la configuration des librairies partagées [type "shlb"] présentes
dans le dossier Extension ou dans un sous-dossier, sans qu'aucune
en particulier puisse être pointée comme responsable
2) la config des périphs usb, et des baies d'extension sur les PowerBook
3) du contenu de la PRAM [les phases de la lune seont hors de cause].

B) En cas de TdFI, reprendre le contrôle de la situation, en essayant :
1) zapper la PRam [démarrer en pressant les touches pomme (trèfle)
+ option (alt) + p + r jusqu'au 3e démarrage]
1') resetter le power manager par le clavier ou par bouton cuda de la
carte-mère (le cuda est au cul de certains portables).
NB: le problème réapparait souvent au démarrage suivant, et/ou en
fonction de la configuration moniteur sauvegardée en PRam.
2) modifier la configuration matérielle du bus USB, en retirant ou
ajoutant des périphériques (souris, clavier, hub, dongle..) que l'on
peut rebrancher une fois démarré. Sur les portables, ajouter ou
retirer un périph de la baie d'extension peut suffire.
NB: le problème réapparait souvent si l'on rétabli exactement la
configuration qui provoquait le plantage, alors même que les périphs
et drivers sont innocents.
3) en cas désespéré : redémarrer depuis le cédé de démarrage livré avec
le mac [insérer le cd, faire reset, presser touche "c" au démarrage]
4) quand on a la main, modifier la configuration des librairies du
dossier Extensions. Par exemple retirer les dossiers "Macromedia"
et/ou "Real" (si l'on peut se passer de Shockwave ou RealPlayer).
Désactiver ou réactiver des extensions inutilisées, genre "Extension
réglages réseau" ou "Biblio. partage de fichiers" pour ceux qui
n'ont pas de réseau, ou encore "Gestion AP AirPort" pour ceux qui
croient que cela ne concerne que Roissy, etc.. NB: les extensions de
type "INIT" et les tableaux de bord n'ont pas d'effet notable.

C) le message apparait quand un certain morceau de code clairement
identifié du boot 3 invoque l'erreur système 27 parce qu'il ne parvient
pas à accéder au fichier "Ressources système", apparemment parce que le
chargement du transcodeur Unicode [nécessaire pour l'accès aux fichiers
comprenant des caractères accentués sur les volumes HFS+] a
préalablement échoué, peut-être selon certaines hypothèses à cause d'un
insuffisance ou d'une fragmentation de la mémoire disponible dans le
system heap.

D) les plus aventureux pouront tenter de Resediter la ressource boot 2
d'une copie du fichier System pour augmenter la taille du system heap au
début du démarrage: sous sytème 9.0 et 9.1 c'est la valeur sur 4 octets
à l'offset 0000BC de la ressource boot 2, remplacer 00A00000 (System
9.1) ou 004E2000 (System 9.0) par 02000000 soit 32Mo.
Je décline toute responsabilité en cas d'inutilité, plantage, perte de
données, désintégration du mac.
nospam
Le #17023851
Michèle
TdFI sur un 8.5 ? Bizarre. Ça concerne OS 9.x



Non, tu devrais (re)lire le post de Roberto un peu plus haut :


Le _faux_ problème de TdFI concerne 9.x, mais il existe un _vrai_
problème de TdFI (beaucoup plus rare, mais aussi plus sérieux) qui, lui,
peut toucher des versions antérieures de MacOS.

A++
--
Christian
"Les mauvaises langues courent la rue et se lèchent les babines"
Photos des Antilles et des Grenadines :
rockaunord
Le #17023841
Bonjour,

Merci pour tes réponses et suggestions mais :

- Ce Mac est en OS 8.X (8.1 ou 8.5, ce que j'aimerais bien verifier si il
voulait démarrer)
- Aucun périphérique connecté en USB (je ne pense d'ailleurs pas qu'il y ai
un port usb sur ce modele de Mac (G3 beige, les premiers sortis)
- Impossible de rebooter sur le CD, impossible aussi de rebooter en
désactivant les extensions : même message d'erreur

Je vais essayer de démarer sur une disquette utilitaire, ou d'installer un
autre disque, pour pouvoir ensuite controler/initialiser le disque ou se
trouve le problème.

Merci quand même pour les infos

Christophe
Publicité
Poster une réponse
Anonyme