[Ubuntu 16.04] Probl=c3=a8me de carte graphique

Le
Olivier Miakinen
Bonjour,

J'ai un problème de reconnaissance de ma carte graphique depuis une
mise à jour mardi dernier.

Voici ce que donne le lspci :
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc.
[AMD/ATI] Juniper XT [Radeon HD 5770]

Mardi matin j'ai accepté une mise à jour, je n'ai pas eu l'impression
qu'il s'agissait d'une mise à niveau, même si je ne me rappelle pas
à quel moment mon Ubuntu 14.04 LTS est passé en 16.04 (oui, je sais,
je ferais un piètre administrateur).

Mardi soir en revenant, l'affichage était passé à 640×480, ce qui fait
un choc par rapport au 1680×1050 habituel. Avec difficulté car ça me
donnait l'impression de devoir travailler à travers le trou de la
serrure, j'ai d'abord vu que la carte graphique n'était plus reconnue
du tout. En cherchant sur Internet, j'ai finalement trouvé un conseil
qui a un peu amélioré les choses : supprimer ~/.config/monitors.xml
m'a permis de passer au moins en 1024×768.

Depuis, j'ai appris que le driver d'origine de ma carte graphique ne
fonctionne pas dans Ubuntu 16.04 et que je dois installer AMDGPU-PRO
en suivant les instructions de cette page :
<http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Install.aspx>.

Mais l'installation ne fonctionne pas. À un moment, le script lance
l'instruction suivante :
sudo apt-get install amdgpu-pro amdgpu-pro-lib32 amdgpu-pro-dkms
et bizarrement c'est le paquet du milieu qu'il ne trouve pas :
==
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture des informations d'état Fait
E: Impossible de trouver le paquet amdgpu-pro-lib32
==

Que puis-je faire pour m'en sortir ?


--
Olivier Miakinen
Vos réponses Page 7 / 7
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jo Engo
Le #26431731
Le Mon, 10 Apr 2017 18:25:07 +0200, Olivier Miakinen a écrit :
Si ça se trouve (et que j'espère)
c'était juste un faux contact qui était la cause de tous mes déboires,
plutôt qu'un véritable problème Linux.


Là ça ressemble à un vrai problème matériel, et la carte vidéo *ou*
l'écran sont visiblement en cause.
--
MATHÉMATIQUES : Dessèchent le coeur.
-+- Gustave Flaubert, Dictionnaire des idées reçues -+-
Olivier Miakinen
Le #26432930
Le 10/04/2017 19:52, Jo Engo me répondait :
Si ça se trouve (et que j'espère)
c'était juste un faux contact qui était la cause de tous mes déboires,
plutôt qu'un véritable problème Linux.

Là ça ressemble à un vrai problème matériel, et la carte vidéo *ou*
l'écran sont visiblement en cause.

Pour ceux que cela intéresse, voici la fin de l'histoire.
Tout d'abord la carte graphique est bel et bien morte, je l'ai
remplacée par une NVIDIA GeForce 9400 GT.
Par ailleurs mon Ubuntu 16.04, résultat de plusieurs années de mises
à jour, était dans un état incohérent. Cela, plus le fait que je me
suis aperçu que c'était une version 32 bits, m'a donné l'envie de
repartir de zéro. Et donc, après avoir sauvegardé /home, j'ai tout
viré pour installer un LinuxMint 18.1 64 bits avec Cinnamon.
Résultat : j'ai un système tout neuf, dans lequel les sept résolutions
préférées de mon écran sont toutes reconnues, jusqu'au 1680 x 1050.
Encore merci à tous pour votre aide.
--
Olivier Miakinen
Publicité
Poster une réponse
Anonyme