partage SMB Mac inaccessible depuis W10 pro

Le
pehache
(xpost conservé)

Bonjour,

Encore des histoires de partages SMB inaccessibles

Cette fois ce sont les partages SMB de mon Mac (sous 10.12) qui sont
inaccessibles depuis mon PC W10 pro du boulot (quand il est sur mon
réseau perso, évidemment).

J'ai imaginé que comme le PC était configuré sur un domaine (de ma
boÍ®te) ça pouvait l'empêcher d'accéder Í  des machines hors domaine. Mais
ce n'est pas ça car il n'a aucun problème pour accéder aux partages SMB
de mon NAS Synology.

Donc le problème pourrait être cÍ´té Mac, sauf que j'ai aussi un PC perso
sous W10 pro, qui lui n'a aucun problème pour accéder aux partages du Mac.

Depuis le PC du boulot :

-
> NET USE Y: \<ip_du_mac><partage> /user:<nom>
System error 121 has occured

The semaphore timeout period has expired

> NET VIEW \<ip_du_mac>
System error 5 has occured

Access denied
-

Note : un ping sur l'IP fonctionne


Bref, je ne sais plus o͹ chercher
  • Partager ce contenu :
Vos réponses Page 1 / 9
Trier par : date / pertinence
JPP
Le #26561292
On 29/11/20 20:01, pehache wrote:
Bref, je ne sais plus o͹ chercher...

Décocher les partages du Mac, (Sys Prefs/Partages)
Eteindre, redémarrer avec Reset PRAM; 2 ou 3 Bong !
Recocher les partages souhaités.
J'ai eu des problèmes similaires entre mes 3 Macs et bidouillé dans tous
les sens pour que ça remarche.
Cela serait peut-être dÍ» Í  une mauvaise connexion initiale mise en cache
de telle sorte que le Mac ne considère pas la nouvelle requête mais le
cache (???)
DuboisP
Le #26561303
Le 30/11/2020 Í  00:01, pehache a écrit :
(xpost conservé)
Bonjour,
Encore des histoires de partages SMB inaccessibles...
Cette fois ce sont les partages SMB de mon Mac (sous 10.12) qui sont
inaccessibles depuis mon PC W10 pro du boulot (quand il est sur mon
réseau perso, évidemment).
J'ai imaginé que comme le PC était configuré sur un domaine (de ma
boÍ®te) ça pouvait l'empêcher d'accéder Í  des machines hors domaine. Mais
ce n'est pas ça car il n'a aucun problème pour accéder aux partages SMB
de mon NAS Synology.
Donc le problème pourrait être cÍ´té Mac, sauf que j'ai aussi un PC perso
sous W10 pro, qui lui n'a aucun problème pour accéder aux partages du Mac.


regarder les couches SMB valides sur toutes les machines
mon hypothèse
ton PC perso est un W10 1511 successivement upgradé. donc le SMB1 reste
validé.
ton PC boulot a été directement buildé en W10 1903 ou plus, qui
n'installe pas le SMB1 (peut être rajouté), ce protocole étant considéré
comme non-sécurisé.
ton Synology accepte indifférement SMB1 Í  SMB3
ton MAC (dont je ne suis pas spécialiste) est en SMB1 seulement
ça semble être le même problème que pour accéder aux partages Freebox
(V6 Samba3 SMB1 only)
pehache
Le #26561310
Le 30/11/2020 Í  09:09, DuboisP a écrit :
Le 30/11/2020 Í  00:01, pehache a écrit :
(xpost conservé)
Bonjour,
Encore des histoires de partages SMB inaccessibles...
Cette fois ce sont les partages SMB de mon Mac (sous 10.12) qui sont
inaccessibles depuis mon PC W10 pro du boulot (quand il est sur mon
réseau perso, évidemment).
J'ai imaginé que comme le PC était configuré sur un domaine (de ma
boÍ®te) ça pouvait l'empêcher d'accéder Í  des machines hors domaine. Mais
ce n'est pas ça car il n'a aucun problème pour accéder aux partages SMB
de mon NAS Synology.
Donc le problème pourrait être cÍ´té Mac, sauf que j'ai aussi un PC perso
sous W10 pro, qui lui n'a aucun problème pour accéder aux partages du Mac.

regarder les couches SMB valides sur toutes les machines

Comment on fait ça (sur PC, sur Mac...) ?
mon hypothèse
ton PC perso est un W10 1511 successivement upgradé. donc le SMB1 reste
validé.

De mémoire (je ne suis pas certain non plus) il était en 1903 quand je
l'ai reçu.
ton PC boulot a été directement buildé en W10 1903 ou plus, qui
n'installe pas le SMB1 (peut être rajouté), ce protocole étant considéré
comme non-sécurisé.

Quand je l'ai eu il était en 1709.
ton Synology accepte indifférement SMB1 Í  SMB3

Exact. L'interface permet d'imposer une version minimum et une version
maxium, je le mettrai en SMB1 only pour voir si le PC arrive toujours Í 
se connecter dessus.
ton MAC (dont je ne suis pas spécialiste) est en SMB1 seulement

Je n'arrive pas Í  trouver l'info... Cette version d'OS date de 2016, ça
me paraitrait curieux qu'il soit SMB1 only...
pehache
Le #26561312
Le 30/11/2020 Í  02:45, JPP a écrit :
On 29/11/20 20:01, pehache wrote:
Bref, je ne sais plus o͹ chercher...

Décocher les partages du Mac, (Sys Prefs/Partages)
Eteindre, redémarrer avec Reset PRAM; 2 ou 3 Bong !
Recocher les partages souhaités.
J'ai eu des problèmes similaires entre mes 3 Macs et bidouillé dans tous
les sens pour que ça remarche.
Cela serait peut-être dÍ» Í  une mauvaise connexion initiale mise en cache
de telle sorte que le Mac ne considère pas la nouvelle requête mais le
cache (? ? ?)


Wahou... Il faut faire des incantations en même temps :-) ?
Bon, en désespoir de cause j'essaierai !
Didier
Le #26561326
Le 30/11/2020 Í  09:47, pehache a écrit :
Le 30/11/2020 Í  09:09, DuboisP a écrit :
Le 30/11/2020 Í  00:01, pehache a écrit :
(xpost conservé)
Bonjour,
Encore des histoires de partages SMB inaccessibles...
Cette fois ce sont les partages SMB de mon Mac (sous 10.12) qui sont
inaccessibles depuis mon PC W10 pro du boulot (quand il est sur mon
réseau perso, évidemment).
J'ai imaginé que comme le PC était configuré sur un domaine (de ma
boÍ®te) ça pouvait l'empêcher d'accéder Í  des machines hors domaine.
Mais ce n'est pas ça car il n'a aucun problème pour accéder aux
partages SMB de mon NAS Synology.
Donc le problème pourrait être cÍ´té Mac, sauf que j'ai aussi un PC
perso sous W10 pro, qui lui n'a aucun problème pour accéder aux
partages du Mac.

regarder les couches SMB valides sur toutes les machines

Comment on fait ça (sur PC, sur Mac...) ?

Sur le PC, dans Panneau de configuration / Programmes et
fonctionnalités, et sur le menu de gauche Activer ou désactiver des
fonctionnalités Windows. Tout en bas de la petite fenêtre, Support de
partage de fichiers SMB 1.0 (CIFS), la première case Í  cocher.
Je suppose qu'il faut redémarrer (je ne suis pas sÍ»r mais ça ne mange
pas trop de pain).
Didier.
Sergio
Le #26561325
Le 30/11/2020 Í  09:47, pehache a écrit :
ton MAC (dont je ne suis pas spécialiste) est en SMB1 seulement

Je n'arrive pas Í  trouver l'info... Cette version d'OS date de 2016, ça me paraitrait curieux qu'il soit SMB1 only...

MacOS doit utiliser Samba (https://fr.wikipedia.org/wiki/Samba_(informatique) ) D'après l'article
SMB2 est supporté depuis la version 3.6 (2011) et SMB3 depuis la version 4.1 (2013).
Sous Linux on en est Í  la version 4.13. J'ignore si MacOS a mis Í  jour les versions...
--
Serge http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
DuboisP
Le #26561324
Le 30/11/2020 Í  09:47, pehache a écrit :
Le 30/11/2020 Í  09:09, DuboisP a écrit :
Le 30/11/2020 Í  00:01, pehache a écrit :
(xpost conservé)
Bonjour,
Encore des histoires de partages SMB inaccessibles...
Cette fois ce sont les partages SMB de mon Mac (sous 10.12) qui sont
inaccessibles depuis mon PC W10 pro du boulot (quand il est sur mon
réseau perso, évidemment).
J'ai imaginé que comme le PC était configuré sur un domaine (de ma
boÍ®te) ça pouvait l'empêcher d'accéder Í  des machines hors domaine.
Mais ce n'est pas ça car il n'a aucun problème pour accéder aux
partages SMB de mon NAS Synology.
Donc le problème pourrait être cÍ´té Mac, sauf que j'ai aussi un PC
perso sous W10 pro, qui lui n'a aucun problème pour accéder aux
partages du Mac.

regarder les couches SMB valides sur toutes les machines

Comment on fait ça (sur PC, sur Mac...) ?

sur PC
au hasard des réponses
https://winaero.com/enable-smb1-sharig-protocol-windows-10/
mon hypothèse
ton PC perso est un W10 1511 successivement upgradé. donc le SMB1
reste validé.

De mémoire (je ne suis pas certain non plus) il était en 1903 quand je
l'ai reçu.
ton PC boulot a été directement buildé en W10 1903 ou plus, qui
n'installe pas le SMB1 (peut être rajouté), ce protocole étant
considéré comme non-sécurisé.

Quand je l'ai eu il était en 1709.

le 1709 n'implémentait pas le SMB 1 par défaut
désolé pour le numéro de version,q ue j'ai donné de mémoire
ton Synology accepte indifférement SMB1 Í  SMB3


j'ai un 1515 :-)
Exact. L'interface permet d'imposer une version minimum et une version
maxium, je le mettrai en SMB1 only pour voir si le PC arrive toujours Í 
se connecter dessus.
ton MAC (dont je ne suis pas spécialiste) est en SMB1 seulement

Je n'arrive pas Í  trouver l'info... Cette version d'OS date de 2016, ça
me paraitrait curieux qu'il soit SMB1 only...


Mac, je ne connais que superficiellement
peut-être un problème de user/password ?
https://miapple.me/macos-fixing-smb-windows-file-sharing-not-working-on-mac/
ou
https://community.spiceworks.com/topic/2202398-10-12-6-imac-workstations-using-smb1
changer la couche Samba, et je dénie toute responsabilité :-)
https://www.tweaking4all.com/os-tips-and-tricks/macosx-tips-and-tricks/smbup-mac-os-x-smb-fix/
https://miapple.me/macos-fixing-smb-windows-file-sharing-not-working-on-mac/
Sergio
Le #26561323
Le 30/11/2020 Í  11:05, Sergio a écrit :
Le 30/11/2020 Í  09:47, pehache a écrit :
ton MAC (dont je ne suis pas spécialiste) est en SMB1 seulement

Je n'arrive pas Í  trouver l'info... Cette version d'OS date de 2016, ça me paraitrait curieux qu'il soit SMB1 only...

MacOS doit utiliser Samba (https://fr.wikipedia.org/wiki/Samba_(informatique) ) D'après l'article
SMB2 est supporté depuis la version 3.6 (2011) et SMB3 depuis la version 4.1 (2013).
Sous Linux on en est Í  la version 4.13. J'ignore si MacOS a mis Í  jour les versions...

Vu dans la doc Linux (https://doc.ubuntu-fr.org/samba )
---------------
Penser au Pare-feu
En cas de problème de connexion, si par exemple, en essayant de parcourir votre réseau, vous obtenez ce message d'erreur: "L'obtention de la liste des partages du serveur a échoué" , regardez la
configuration du pare-feu de chaque machine.
----------------
--
Serge http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
pehache
Le #26561338
(repost car Nemo semble avoir des vapeurs)
Le 30/11/2020 Í  11:05, Sergio a écrit :
Le 30/11/2020 Í  09:47, pehache a écrit :
ton MAC (dont je ne suis pas spécialiste) est en SMB1 seulement

Je n'arrive pas Í  trouver l'info... Cette version d'OS date de 2016,
ça me paraitrait curieux qu'il soit SMB1 only...

MacOS doit utiliser Samba

(https://fr.wikipedia.org/wiki/Samba_(informatique) )
D'après l'articleSMB2 est supporté depuis la version 3.6 (2011) et
SMB3 depuis la version 4.1 (2013).Sous Linux on en est Í  la version
4.13. J'ignore si MacOS a mis Í  jour les versions...

En fait macOS n'utilise plus Samba depuis un moment, mais a développé
son propre client/serveur :
https://www.osnews.com/story/24572/apple-ditches-samba-in-favour-of-homegrown-replacement/
Il est censé gérer le SMB2...
pehache
Le #26561337
(repost car Nemo semble avoir des vapeurs)
Le 30/11/2020 Í  11:01, Didier a écrit :
Le 30/11/2020 Í  09:47, pehache a écrit :
Le 30/11/2020 Í  09:09, DuboisP a écrit :
Le 30/11/2020 Í  00:01, pehache a écrit :
(xpost conservé)
Bonjour,
Encore des histoires de partages SMB inaccessibles...
Cette fois ce sont les partages SMB de mon Mac (sous 10.12) qui sont
inaccessibles depuis mon PC W10 pro du boulot (quand il est sur mon
réseau perso, évidemment).
J'ai imaginé que comme le PC était configuré sur un domaine (de ma
boÍ®te) ça pouvait l'empêcher d'accéder Í  des machines hors domaine.
Mais ce n'est pas ça car il n'a aucun problème pour accéder aux
partages SMB de mon NAS Synology.
Donc le problème pourrait être cÍ´té Mac, sauf que j'ai aussi un PC
perso sous W10 pro, qui lui n'a aucun problème pour accéder aux
partages du Mac.

regarder les couches SMB valides sur toutes les machines

Comment on fait ça (sur PC, sur Mac...) ?

Sur le PC, dans Panneau de configuration / Programmes et
fonctionnalités, et sur le menu de gauche Activer ou désactiver des
fonctionnalités Windows.

Inaccessible (même en lecture) sans les droits admin, que ma boÍ®te
n'accorde pas :( (ça me gonfle régulièrement vu tout ce qui est
impossible Í  faire sous Windows sans les droits admin, mais c'est un
autre sujet...)
Tout en bas de la petite fenêtre, Support de
partage de fichiers SMB 1.0 (CIFS), la première case Í  cocher.
Je suppose qu'il faut redémarrer (je ne suis pas sÍ»r mais ça ne mange
pas trop de pain).
Didier.
Poster une réponse
Anonyme