PC éteint qui consomme

Le
François Boisson
Bonjour la liste,

J'ai la chance d'avoir un Toshiba Portege sous Debia/Wheezy et un Toshiba
satellite (A500 je crois) désormais sous Wheezy.

Le second est essentiellement sous secteur mais le premier vue son autonomie
est souvent sous batterie. J'ai constaté plusieurs fois que la charge de la
batterie du portege baissait au cours de la nuit. Cela m'a étonné car lorsque
mon toshiba sattelite était sous Squeeze, la charge de la batterie se
conservait pendant les vacances (je ne prends pas de portables en vacances),.
J'ai donc fait les expériences suivantes:

* Les deux Toshiba sous wheezy, allumés et arrêtés sous Wheezy laissés
quelques jours: la charge de la batterie baisse considérablement et
constamment. En attendant assez longtemps, on arrive à une charge de 0%
partant d'une batterie à 100%. (Baisse de 8-10% en une nuit pour le portege)

* Le Toshiba portége, allumé sous Windows 7 puis aussitôt éteint, conserve sa
charge à 100% pendant des jours.

Il y a donc un souci spécifique à la Wheezy. Je pense (mais n'ai pas la
preuve) que ce souci n'existait pas sous Squeeze.

Les noyaux sont respectivement un 3.3.0-rc4 pour le portege et un 3.2.0-2 pour
le satellite (les deux en AMD64).

Si ça consomme c'est que quelque chose est allumés, j'ai donc essayé de voir
les points suivants:
* Les ports USB (possibilité de charger un bazar même si le PC est éteint).
Echec, un périphérique sur ce port ne fait rien, pas de charge ni quoi que ce
soit.
* Le port ethernet actif. Je doute, tout d'abord parce que j'ai bien veillé
dans les deux cas à mettre l'option
HALT=poweroff
dans /etc/default/halt , que j'ai renchéri en forçant cette option
dans /etc/init.d/halt pour être sur, que le wakeonlan ne fonctionne pas
(c'était voulu) et que enfin aucune activité réseau sur les loupîottes n'est
visibles. Bref, je crois fermement que cette carte réseau est éteinte.
* Il reste le WIFI, là je n'ai pas trop d'idées pour vérifier que le WIFI
n'est pas actif. À tout hasard, j'ai rajouté dans /etc/init.d/wicd lors de
l'arrêt ifconfig eth0 down et ifconfig wlan0 down mais (comme prévu), ça n'a
pas changé les choses.

À ce stade je sèche et ça m'énerve, être obliger d'éteindre discrètement sa
machine en passant par windows 7 pour ne pas perdre de la batterie du portege
ou trouver un argument bidon pour justifier le retrait de la batterie du
Toshiba satellite est plutôt pénible.

Je suis à l'écoute de toutes idées et suggestions mais ne vous gachez pas une
belle journée d'été pour ça tout de même.

François Boisson

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20120816182700.b3585286d182c7758015e724@maison.homelinux.net
Vos réponses Page 2 / 9
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
andre_debian
Le #24711502
On Tuesday 21 August 2012 11:28:55 Gaël wrote:
j'ai le même soucis avec un ordinateur sous ubuntu 12.04. Chargé à bloc,
éteint et débranché pendant 5 jours, à l'allumage, reste 20% de b atterie...
étonnant ! Gaël



Ce n'est pas :
"la pile Wonder, ne s'use que si l'on s'en sert"

Il doit y avoir qu'un petit court-circuit dans le PC.
Pour le voir, recharger la batterie à fond,
la retirer du PC pendant quelques jours puis vérifier sa charge ...
Si elle est au top, il y a un court-circuit quelque part.
L'OS n'est pas responsable ici.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
andre_debian
Le #24711582
On Tuesday 21 August 2012 11:28:55 Gaël wrote:
j'ai le même soucis avec un ordinateur sous ubuntu 12.04. Chargé à bloc,
éteint et débranché pendant 5 jours, à l'allumage, reste 20% de b atterie...
étonnant !  Gaël

On Tue, Aug 21, 2012 at 11:57:47AM +0200,
wrote:
> Il doit y avoir qu'un petit court-circuit dans le PC.
> Pour le voir, recharger la batterie à fond,
> la retirer du PC pendant quelques jours puis vérifier sa charge ...
> Si elle est au top, il y a un court-circuit quelque part.
> L'OS n'est pas responsable ici.



On Tuesday 21 August 2012 12:01:29 JF Straeten wrote:
Mmmm... comment t'explique qu'il n'ait pas le problème sous Windows 7
dans ce cas ? A+ JFS.



Mmmm... il faut lire le mail original.
Gaël indique (cf ci-dessus) :
PC chargé à bloc, ÉTEINT ET DÉBRANCHÉ, pendant 5 jours ...

Dans ces conditions, en quoi un OS peut-il être responsable
de fuite de courant de la batterie ?

andré

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
JF Straeten
Le #24711592
Re,

On Tue, Aug 21, 2012 at 11:57:47AM +0200, wrote:

[...]

Il doit y avoir qu'un petit court-circuit dans le PC.
Pour le voir, recharger la batterie à fond,
la retirer du PC pendant quelques jours puis vérifier sa charge ...
Si elle est au top, il y a un court-circuit quelque part.
L'OS n'est pas responsable ici.



Mmmm... comment t'explique qu'il n'ait pas le problème sous Windows 7
dans ce cas ?

A+

--

JFS.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
maderios
Le #24711572
Ça ne pourrait pas être un problème avec la nouvelle fonctionnalité
WOWLAN (Wake on Wireless LAN), supportée à partir des noyaux 3.1 ? Ça
doit certainement consommer pas mal !



Ah , je ne connaissais pas cette option là. Je vais vérifier mais ça doit être
ça....



Le module Intel Wireless WiFi Next Gen AGN -
Wireless-N/Advanced-N/Ultimate-N (iwlwifi) "pourrait peut-être"
(conditionnel) en être la cause.

Il suffirait donc de l'empêcher d'être chargé lors du boot.

http://www.phoronix.com/scan.php?page=news_item&px=OTgwMg

https://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;hÈac61cf6e53fefb3b439fc58390fb65d2730e63

Chez moi ce module n'est pas compilé

Make menuconfig noyau 3.4.8

Symbol: IWLWIFI [=n]

│ Type : tristate

│ Prompt: Intel Wireless WiFi Next Gen AGN -
Wireless-N/Advanced-N/Ultimate-N (iwlwifi) │
│ Defined at drivers/net/wireless/iwlwifi

--
Maderios

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
JF Straeten
Le #24711642
Re,

On Tue, Aug 21, 2012 at 12:07:27PM +0200, wrote:

Mmmm... il faut lire le mail original.
Gaël indique (cf ci-dessus) :
PC chargé à bloc, ÉTEINT ET DÉBRANCHÉ, pendant 5 jours ...

Dans ces conditions, en quoi un OS peut-il être responsable
de fuite de courant de la batterie ?



J'ai vu.

Parce qu'il (l'OS) n'aurait pas éteint absolument tous les
composants ? Un truc est laissé dans un état qui le fait consommer ?

Je n'incrimine pas gratuitement l'OS, je cherche à comprendre pourquoi
François (à l'origine) éprouve ça sous Linux et pas sous Seven ?

A+

--

JFS.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Mourad Jaber
Le #24711682
On 21/08/2012 12:14, JF Straeten wrote:
Re,

On Tue, Aug 21, 2012 at 12:07:27PM +0200, wrote:

Mmmm... il faut lire le mail original.
Gaël indique (cf ci-dessus) :
PC chargé à bloc, ÉTEINT ET DÉBRANCHÉ, pendant 5 jours ...

Dans ces conditions, en quoi un OS peut-il être responsable
de fuite de courant de la batterie ?


J'ai vu.

Parce qu'il (l'OS) n'aurait pas éteint absolument tous les
composants ? Un truc est laissé dans un état qui le fait consommer ?


Le constat est là ! plusieurs personnes (dont ma pomme) ont le même type de comportement
sur des marques de portable différents.
Pour ma part, je croyais au départ que c'était la batterie qui ne tenait plus la charge,
mais force est de constaté que sous windows ou des anciens noyau, ce comportement ne se
produit pas !

Ceci permet d'écarter la thèse du matériel défectueux et donc de faire l'hypothèse que le
noyau laisse quelque chose "allumé à l'arrêt"...

Autre test que j'ai fait, si je retire la batterie du portable, elle garde sa charge sans
problème...

++

Mourad

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
andre_debian
Le #24711742
On Tuesday 21 August 2012 12:37:19 Mourad Jaber wrote:
On 21/08/2012 12:14, JF Straeten wrote:
> On Tue, Aug 21, 2012 at 12:07:27PM +0200,


wrote:
>> Mmmm... il faut lire le mail original.
>> Gaël indique (cf ci-dessus) :
>> PC chargé à bloc, ÉTEINT ET DÉBRANCHÉ, pendant 5 jours ...
>>
>> Dans ces conditions, en quoi un OS peut-il être responsable
>> de fuite de courant de la batterie ?
> J'ai vu.

> Parce qu'il (l'OS) n'aurait pas éteint absolument tous les
> composants ? Un truc est laissé dans un état qui le fait consommer ?

Le constat est là ! plusieurs personnes (dont ma pomme) ont le même t ype de
comportement sur des marques de portable différents.
Pour ma part, je croyais au départ que c'était la batterie qui ne ten ait
plus la charge, mais force est de constaté que sous windows ou des anci ens
noyau, ce comportement ne se produit pas !
Ceci permet d'écarter la thèse du matériel défectueux et donc de faire
l'hypothèse que le noyau laisse quelque chose "allumé à l'arrêt". ..
Autre test que j'ai fait, si je retire la batterie du portable, elle garde
sa charge sans problème... ++ Mourad



Comment un OS peut-il faire consommer la batterie d'un portable
éteint et surtout câble électrique DÉBRANCHÉ ?
Dans ces conditions, le système n'a plus d'influence sur le PC.

Sinon, la pile du BIOS peut jouer un rôle mais lequel et comment ?
(mémorisation d'une action programmée sur le Bios ... ?)

andré

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
JF Straeten
Le #24711802
Re,

On Tue, Aug 21, 2012 at 01:02:37PM +0200, wrote:

[...]

Comment un OS peut-il faire consommer la batterie d'un portable
éteint et surtout câble électrique DÉBRANCHÉ ?
Dans ces conditions, le système n'a plus d'influence sur le PC.



Si. Ça se joue *avant extinction*. L'OS écrit des trucs dans des
espèces de registres de certains périphériques...

Par exemple, pour avoir le WOL sur une carte réseau, il faut
positionner un "indicateur" sur la carte qui la place dans un état
réceptif au Magic Packet au lancement suivant.

Je soupçonnerais un truc dans ce goût là ici, mais qui consiste à
oublier de dire d'éteindre...

C'est juste une idée pour essayer de faire avancer le schmilblick.

A+

--

JFS.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Nicolas FRANCOIS
Le #24711822
Le Tue, 21 Aug 2012 13:02:37 +0200,
a écrit :

Comment un OS peut-il faire consommer la batterie d'un portable
éteint et surtout câble électrique DÉBRANCHÉ ?
Dans ces conditions, le système n'a plus d'influence sur le PC.



Si le PC est en mode "Wake On Lan", il y a forcément un composant qui
n'est pas complètement éteint pour pouvoir "écouter" la prise Ehernet,
non ?

C'est pareil avec le WOWLAN (WOL sur le Wifi), sauf que là, à mon avis,
ça consomme plus.

Si Linux sait ce que c'est que le WOWLAN, et qu'il l'active par défaut,
alors que Window$ ne le sait pas, c'est alors normal qu'il y ait une
différence de comportement : l'un met en route le module avant
d'éteindre la machine, l'autre pas.

Sinon, la pile du BIOS peut jouer un rôle mais lequel et comment ?
(mémorisation d'une action programmée sur le Bios ... ?)



C'est pas le BIOS, puisque c'est pas pareil à chaque fois.

bye

--

Nicolas FRANCOIS | /
http://nicolas.francois.free.fr | |__|
X--/\
We are the Micro$oft. __V
Resistance is futile.
You will be assimilated. darthvader penguin

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bzzz
Le #24711852
On Tue, 21 Aug 2012 09:45:04 +0200
Francois Boisson

Quand on arrête le PC, il y a une consommation correspondant à
0,6% de la batterie par heure soit 9,5Wh consommé soit en gros
40mA



Ça fait bcp 40 mA: vraisemblablement pas un device en veille (c'est
trop pour ça, à moins d'une greffe sauvage de dernière minut e), mais
plutôt un device fully operational.

Vu le comportement que tu décris, ça va être Tgalère à décortiquer
parce qu'il va falloir ne pas charger les modules un par un (en
espérant qu'il n'y-ait pas de démarrage hard auto du device qui p ompe
la batterie) ET effectuer d'abord un arrêt s/s w$, puis un autre
s/s Linux pour que les conditions de tests soient correctes (le tout
dans cet ordre).

Avec le Nb de modules habituellement chargés, le mieux serait de
pouvoir bricoler une dummy battery, pour pouvoir intercaler un
ampèremètre entre laptop et batterie; sinon tu vas devoir tester
nuit par nuit :(

Et si tu procèdes comme cela, ne recharge pas les modules déjà   testés
parce qu'il peut y a voir une interaction entre plusieurs modules.

Perso, je commencerai par faire la même chose mais avec les daemons,
on ne sait jamais…

JY
--
<guend> on critique windoz, on critique windoz...
<guend> moi depuis que j'ai mon nouvel ordi, j'ai aucun pb avec
<kayoch> mais tu viens pas d'acheter un mac??
<guend> si et alors?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme