Le
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
pehache
Le #26537424
Le 04/02/2020 à 01:01, Francois LE COAT a écrit :
Ce n'est pas clair si tu l'as déjà fait ou pas, mais à ta place je
tenterais de reprendre à zéro l'installation de MacPorts et des
paquets en suivant bien les instructions de désinstallation complète
et d'installation :
https://guide.macports.org/chunked/installing.macports.uninstalling.html
https://guide.macports.org/chunked/installing.macports.html

J'ai suivi la procédure. J'ai désinstallé, puis installé, et ça marche.
J'ai pu installer ffmpeg, opencv et youtube-dl avec succès. Le problème
provenait probablement de la migration de Snow Leopard à Mojave. En tous
cas, maintenant j'ai réussi à installer tout ce que je voulais.


Super :-)
Note que j'avais posé la question : "Juste pour être sûr : tu as bien
réinstallé MacPorts en passant à Mojave, tu ne l'as pas juste migré
depuis Snow Leopard ?" (02/02 22h12), sans avoir de réponse claire...
Quant on fait une migration de version de macOS il faut réinstaller tous
les paquets car ils sont compilés spécifiquement pour le couple
machine/OS sur lequel ils sont installés.
Pour simplifier la réinstallation des paquets, le manuel propose une
procédure de migration de MacPorts (que j'ai appliquée à 2 ou 3 reprises
et qui fonctionne bien) :
https://trac.macports.org/wiki/Migration
--
"...sois ouvert aux idées des autres pour peu qu'elles aillent dans le
même sens que les tiennes.", ST sur fr.bio.medecine
Publicité
Poster une réponse
Anonyme